At First i had this error log

League\OAuth2\Server\Exception\OAuthServerException: Client authentication

don't know where to look, creating client, make sure the same value in database no luck

then in consumer site tried to dump error then shows

cURL error 60: SSL certificate prblm: unable to get local issuer certificate

pretty sure i failed in https, because my local site is on https

Rough patch (didnt want to update code so)

open vendor\guzzlehttp\guzzle\src\Handler\CurlFactory.php
and change this

$conf[CURLOPT_SSL_VERIFYHOST] = 2;
$conf[CURLOPT_SSL_VERIFYPEER] = true;
to this

$conf[CURLOPT_SSL_VERIFYHOST] = 0;
$conf[CURLOPT_SSL_VERIFYPEER] = FALSE;

Probably the right way

$guzzleClient = new \GuzzleHttp\Client(array( 'curl' => array( CURLOPT_SSL_VERIFYPEER => false, ), ));
$client->setHttpClient($guzzleClient);

Issues on installing in laravel 5.5

so in the documentation it says for this version need to install this

composer require laravel/passport=~4.0

tried it but failed

Problem 1
- Conclusion: don't install laravel/passport v4.0.3
- Conclusion: don't install laravel/passport v4.0.2
- Conclusion: don't install laravel/passport v4.0.1
- Conclusion: remove firebase/php-jwt v5.0.0
- Installation request for paragonie/random_compat (locked at v9.99.99) -> satisfiable by paragonie/random_compat[v9.99.99].
- Installation request for laravel/passport ~4.0 -> satisfiable by laravel/passport[v4.0.0, v4.0.1, v4.0.2, v4.0.3].
- Conclusion: don't install firebase/php-jwt v5.0.0
- laravel/passport v4.0.0 requires firebase/php-jwt ~3.0|~4.0 -> satisfiable by firebase/php-jwt[v3.0.0, v4.0.0].
- Can only install one of: firebase/php-jwt[v3.0.0, v5.0.0].
- Can only install one of: firebase/php-jwt[v4.0.0, v5.0.0].
- Installation request for firebase/php-jwt (locked at v5.0.0) -> satisfiable by firebase/php-jwt[v5.0.0].

So I installed this

composer require paragonie/random_compat

but it got me v9.99.99 wew...
so this is what needs to be done.. need to be more spesific

composer require paragonie/random_compat:2.*

Then installing Passport 4.0 works